AIX 5L Differences Guide Version 5.1 Edition
Total Page:16
File Type:pdf, Size:1020Kb
AIX 5L Differences Guide Version 5.1 Edition AIX 5L - The industrial strength UNIX operating system Intel Itanium-based and IBM POWER-based platform support Version 5.0 and Version 5.1 enhancements explained René Akeret Anke Hollanders Stuart Lane Antony Peterson ibm.com/redbooks SG24-5765-01 International Technical Support Organization AIX 5L Differences Guide Version 5.1 Edition June 2001 Take Note! Before using this information and the product it supports, be sure to read the general information in Appendix B, “Special notices” on page 473. Second Edition (June 2001) This edition applies to AIX 5L for POWER Version 5.1, program number 5765-E61 and for Itanium-based systems Version 5.1, program number 5799-EAR available as an PRPQ. This document was updated on September 28, 2001. Comments may be addressed to: IBM Corporation, International Technical Support Organization Dept. JN9B Building 003 Internal Zip 2834 11400 Burnet Road Austin, Texas 78758-3493 When you send information to IBM, you grant IBM a non-exclusive right to use or distribute the information in any way it believes appropriate without incurring any obligation to you. © Copyright International Business Machines Corporation 2001. All rights reserved. Note to U.S Government Users – Documentation related to restricted rights – Use, duplication or disclosure is subject to restrictions set forth in GSA ADP Schedule Contract with IBM Corp. Contents Figures. .xiii Tables. .xix Preface. .xxi The team that wrote this redbook. xxi Comments welcome. xxvi Chapter 1. AIX 5L introduction and overview . 1 1.1 AIX 5L kernel and application development differences summary . 6 1.2 AIX 5L 64-bit kernel overview . 7 1.2.1 Why is a 64-bit kernel needed? . 8 1.2.2 How the AIX VMM maps to the IA64 architecture . 8 1.2.3 64-bit kernel considerations . 10 1.2.4 Selecting the 64-bit kernel on POWER systems . 10 1.2.5 Adapters supported on 64-bit kernel . 12 Chapter 2. Development environment and tool enhancements . 15 2.1 Large data type support - binary compatibility . 15 2.2 DBX enhancements . 15 2.3 Pthread differences and enhancements . 17 2.3.1 Debug library . 17 2.3.2 Unregister atfork handler . 17 2.3.3 Atfork and cancellation cleanup handler support (5.1.0) . 18 2.3.4 Wait list and pthread state information enhancements (5.1.0). 19 2.3.5 Signal context support enhancements (5.1.0) . 19 2.3.6 Deadlock detection (5.1.0) . 20 2.3.7 Resource query support (5.1.0) . 21 2.3.8 Multiple read/write lock read owners. 21 2.4 Thread level resource collection (5.1.0) . 21 2.5 KDB kernel debugger and kdb command enhancements . 22 2.5.1 Kernel debugger introduction . 22 2.5.2 New functions and enhancements (5.1.0). 22 2.6 IADB kernel debugger for Itanium-based systems (5.1.0). 26 2.6.1 The Boot Loader menu . 26 2.6.2 The bosboot command . 28 2.6.3 The breakpoint function . 28 2.6.4 Code display of the kernel debugger . 29 2.7 The iadb command (5.1.0) . 30 2.7.1 Differences between IADB and iadb . 31 2.7.2 Relation between iadb, kdb, or crash . 31 © Copyright IBM Corp. 2001 iii 2.8 Kernel scalability enhancements for SMP machines (5.1.0) . 31 2.8.1 Proch callouts implementation . 31 2.9 Context switch avoidance. 32 2.10 Very large program support . 33 2.11 Lightweight core file support. 34 2.12 Core file naming enhancements (5.1.0) . 34 2.12.1 File naming. 34 2.12.2 Error log entry . 35 2.13 Gathering core files (5.1.0) . 36 2.13.1 Using the snapcore command . 36 2.13.2 Using check_core utility . 37 2.14 Pluggable Authentication Mechanism security support (5.1.0) . 38 2.15 Malloc enhancements. 38 2.15.1 Malloc multiheap. 38 2.15.2 Malloc buckets . 39 2.16 Software vital product data (5.1.0) . 39 2.17 Non-sparseness support for the restore command . 41 2.18 The pax command enhancements . 42 2.19 The snap command enhancements (5.1.0). 42 2.19.1 Flag enhancements . 43 2.19.2 The -T flag enhancements . 44 2.20 KornShell enhancements . 45 2.20.1 ksh93 . 45 2.20.2 New value for shell attribute . 46 2.21 Perl 5.6 (5.1.0) . 46 2.21.1 Installing more than one Perl version . 46 2.21.2 Security considerations. 47 2.22 32-bit and 64-bit Java for Itanium-based platform (5.1.0) . 47 2.23 Java security enhancements (5.1.0) . 48 2.23.1 Certificate Management Protocol . 48 2.23.2 Java Cryptography Extension . 49 2.23.3 Java Secure Sockets Extension . 49 2.23.4 Public-Key Cryptography Standards . 49 2.24 Java currency. 49 Chapter 3. LVM and file system enhancements . 51 3.1 Summary of the enhancements . 51 3.2 LVM enhancements . 52 3.2.1 The redefinevg command . 52 3.2.2 Read-only varyonvg . 52 3.2.3 LVM hot spare disk in a volume group . 52 3.2.4 Support for different logical track group sizes . 61 3.2.5 LVM hot-spot management. 63 iv AIX 5L Differences Guide Version 5.1 Edition 3.2.6 The migratelp command . 73 3.2.7 The recreatevg command . 74 3.2.8 The mkvg command (5.1.0) . 74 3.2.9 The mklv and extendlv command (5.1.0) . 75 3.3 The /proc file system . 77 3.4 The enhanced Journaled File System. 81 3.4.1 What’s new in JFS2? . 82 3.4.2 Compatibility. 84 3.4.3 Commands and utilities changes . 86 3.4.4 JFS2 rootvg support for 64-bit systems (5.1.0) . 93 3.4.5 Performance enhancements (5.1.0) . 95 3.5 NFS statd multithreading . 96 3.6 Multithreaded AutoFS. 97 3.7 Cache file system enhancements . 97 3.7.1 The cachefslog command (5.1.0) . 97 3.8 Passive mirror write consistency check . 99 3.9 Thread-safe liblvm.a. 100 3.10 The .indirect for JFS (5.1.0) . 101 3.11 Complex inode lock (5.1.0). 101 3.12 Uppercase mapping for ISO CD-ROM file systems (5.1.0) . 102 3.13 The root file system ownership . 103 Chapter 4. System management and utility enhancements. 105 4.1 Software license agreement enhancements (5.1.0) . 105 4.1.1 The inulag command . 106 4.1.2 installp enhancements . 106 4.1.3 The lslpp command enhancements . ..